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1. Getting Started 

1.1 Public Users 
The TIMB website (https://timb.co.zw) provides comprehensive information about the 

tobacco industry in Zimbabwe, market statistics, grower resources, and news updates. 

 

To navigate the public portal: 

• Visit https://timb.co.zw 

• Use the top navigation menu to browse: 

•    • HOME - Landing page with hero slider and latest updates 

•    • ABOUT US - Organization information (Vision, Mission, History, Board, 

Management) 

•    • GROWERS - Resources for tobacco farmers (Farming Calendar, Business 

Initiatives, Sustainability) 

•    • RESOURCES - Publications and Reports 

•    • NEWS - Latest updates (Media coverage and Blog posts) 

•    • EVENTS - Industry events and conferences 

•    • CONTACT US - Get in touch with TIMB 

•    • HELPDESK - Support resources 

• View real-time tobacco market statistics in the top banner (Day, Sold Mass, YTD 

Mass, Average Price) 

• Access contact information (phone, email) and social media links in the header 

• Use the search functionality (if available) to find specific content 

 

      Tip: The site is fully responsive and works on desktop, tablet, and mobile devices. 

Use the mobile menu icon (☰) on smaller screens to access navigation. 

1.2 Admins & Editors 

Staff members with administrative access can manage website content through the 

WordPress admin panel. 

 

Logging In 

1. 1. Navigate to https://timb.co.zw/wp-admin/ 

2. 2. Enter your TIMB email address or username 

3. 3. Enter your secure password 

4. 4. Click 'Log In' 

5. 5. If two-factor authentication (2FA) is enabled, complete the verification 

6. 6. Upon successful login, you'll be directed to the WordPress Dashboard 



 

    Security Note: Never share your login credentials. Use a strong, unique password 

and enable two-factor authentication for enhanced security. Always log out when 

finished, especially on shared computers. 

First-Time Login 

If this is your first login or you've been assigned new credentials, you may be prompted 

to change your password. Follow the on-screen instructions to set a strong password 

that meets the security requirements. 

1.3 Admin Dashboard / Workspace 

The WordPress Dashboard is your central hub for managing the TIMB website. The 

dashboard layout and available options depend on your user role and permissions. 

Dashboard Components 

• Left Sidebar Navigation: Main menu for accessing all WordPress features 

• Top Admin Bar: Quick access to site preview, updates, and your profile 

• Dashboard Widgets: At-a-glance view of site activity, quick drafts, and WordPress 

news 

• Content Stats: Overview of published posts, pages, and comments 

• Recent Activity: Latest actions on your site 

 

Note: Users with limited permissions will see only the menu items and features they're 

authorized to access. Contact your administrator if you need additional permissions. 

  



2. Public Portal Overview 
The TIMB website serves as the primary information source for tobacco growers, 

buyers, industry stakeholders, and the general public. Here's a detailed overview of each 

section: 

HOME 

Landing page with hero slider showcasing key messages, real-time tobacco market 

statistics, latest news updates, and featured content 

 

Key features: 

• • Hero slider with multiple slides 

• • Live market data (Day, Sold Mass, YTD, Average Price) 

• • Latest news and announcements 

• • Quick links to key resources 

 

ABOUT US 

Comprehensive information about TIMB's organizational structure, history, and 

leadership 

 

Key features: 

• • Vision, Mission, Values 

• • History and background 

• • Functions & Services 

• • The Board (Board members and their profiles) 

• • Management team 

 

GROWERS 

Dedicated resources and information for tobacco farmers 

 

Key features: 

• • Farming Calendar (seasonal guidelines) 

• • Business Initiatives 

• • Sustainability programs 



 

RESOURCES 

Downloadable documents and reference materials 

 

Key features: 

• • Publications (industry reports, guides) 

• • Reports (annual reports, statistics) 

 

NEWS 

Latest updates and media coverage 

 

Key features: 

• • What The Media Says About Us 

• • Blog (TIMB's official blog posts) 

 

EVENTS 

Information about industry events and conferences 

 

Key features: 

• • WT Africa (World Tobacco Africa) 

• • Other tobacco industry events 

 

CONTACT US 

Multiple ways to reach TIMB 

 

Key features: 

• • Contact form 

• • Office address and location map 

• • Phone and email 

• • Operating hours 



 

HELPDESK 

Support and assistance resources 

 

Key features: 

• • FAQs 

• • Support tickets 

• • Help guides 

 

Additional Features 

• Top Banner Statistics: Real-time tobacco auction data including daily sales, year-

to-date mass, and average prices 

• Social Media Integration: Quick links to TIMB's social media profiles (Facebook, 

X/Twitter, YouTube, Instagram, LinkedIn) 

• Contact Information Bar: Prominent display of TIMB's physical address and phone 

number 

• Responsive Design: Optimized viewing experience across all devices (desktop, 

tablet, mobile) 

• Search Functionality: Ability to search across all website content (if implemented) 

  



3. Core Admin Tasks 
This section covers the most common content management tasks that administrators 

and editors perform on the TIMB website. 

3.1 Managing Pages 

Pages are used for static content such as About Us, Contact, Services, etc. 

Creating a New Page 

7. 1. Navigate to Pages → Add New from the left sidebar 

8. 2. Enter a descriptive page title 

9. 3. Add content using the block editor (Elementor) or page builder 

10. 4. Select appropriate parent page if creating a subpage 

11. 5. Choose page template (Full Width, Sidebar, etc.) 

12. 6. Set featured image if required by template 

13. 7. Configure SEO settings (meta title, description) 

14. 8. Click 'Publish' or 'Save Draft' 

Editing Existing Pages 

15. 1. Navigate to Pages → All Pages 

16. 2. Hover over the page title and click 'Edit' 

17. 3. Make necessary changes to content 

18. 4. Update images, text, or layout as needed 

19. 5. Review changes in Preview mode 

20. 6. Click 'Update' to save changes 

3.2 Managing News & Blog Posts 

Keep stakeholders informed with regular news updates and blog articles. 

Creating a News Post 

21. 1. Navigate to Posts → Add New 

22. 2. Enter an engaging post title 

23. 3. Add content with formatting (headings, paragraphs, lists) 

24. 4. Insert images and media where relevant 

25. 5. Select appropriate categories (News, Media Coverage, Blog, etc.) 

26. 6. Add relevant tags for better organization 

27. 7. Set featured image (highly recommended - shows in listings) 

28. 8. Write an excerpt (summary) for archive pages 

29. 9. Configure SEO settings 

30. 10. Choose publish date (immediate or scheduled) 

31. 11. Click 'Publish' or 'Save Draft' 

 

      Best Practice: Always include a featured image for news posts. This image appears 

in news listings and social media shares. Recommended size: 1200 x 630 pixels. 



3.3 Media Library Management 

The Media Library stores all images, documents, and files used on the website. 

Uploading Media 

32. 1. Navigate to Media → Add New 

33. 2. Click 'Select Files' or drag and drop files 

34. 3. Wait for upload to complete 

35. 4. Add title, caption, alt text, and description 

36. 5. Click 'Save' to store metadata 

Image Optimization Guidelines 

• Resize images before uploading (use actual display size) 

• Compress images to reduce file size (target: under 500KB) 

• Use JPG format for photographs 

• Use PNG format for logos and graphics with transparency 

• Use descriptive filenames (e.g., 'tobacco-auction-2025.jpg') 

• Always add alt text for accessibility and SEO 

• Recommended dimensions: 

• - Featured images: 1200 x 630 px 

• - Hero/banner images: 1920 x 800 px 

• - Gallery images: 800 x 600 px 

3.4 Menu Management 

Menus control the main navigation structure of the website. 

Editing Menus 

37. 1. Navigate to Appearance → Menus 

38. 2. Select the menu to edit (e.g., 'Primary Menu', 'Footer Menu') 

39. 3. Add items from Pages, Posts, Custom Links, or Categories 

40. 4. Drag and drop to reorder menu items 

41. 5. Create dropdown submenus by dragging items to the right 

42. 6. Click the arrow on each item to configure: 

43.    - Navigation Label (text displayed) 

44.    - Title Attribute (tooltip) 

45.    - CSS Classes (for styling) 

46.    - Open in new tab option 

47. 11. Click 'Save Menu' 

 

    Important: Be cautious when modifying the main navigation menu. Test all links 

after saving changes to ensure they work correctly. 



3.5 Publications Management 

Publications include annual reports, research papers, guides, and other downloadable 

documents. 

Adding a Publication 

48. 1. Prepare the document (PDF format recommended) 

49. 2. Create a cover image or thumbnail (recommended: 600 x 800 px) 

50. 3. Navigate to the Publications section in admin panel 

51. 4. Click 'Add New Publication' 

52. 5. Enter title and description 

53. 6. Upload the PDF document 

54. 7. Upload cover image/thumbnail 

55. 8. Select category (Annual Report, Research, Guide, etc.) 

56. 9. Add publication date 

57. 10. Set visibility (Published/Draft) 

58. 11. Save or publish 

3.6 Events Management 
Keep stakeholders informed about upcoming industry events, conferences, and 

workshops. 

Creating an Event 

59. 1. Navigate to Events section (or Posts → Add New with Event category) 

60. 2. Enter event title 

61. 3. Add detailed event description including: 

62.    - Date and time 

63.    - Venue/location 

64.    - Event program/agenda 

65.    - Registration information 

66.    - Contact details 

67. 9. Upload event banner/featured image 

68. 10. Add event category (Conference, Workshop, Auction, etc.) 

69. 11. Set event date 

70. 12. Add registration link if applicable 

71. 13. Publish or schedule 

3.7 Updating Market Statistics 
The top banner displays real-time tobacco market statistics. These should be updated 

daily during auction season. 

Updating Statistics 

72. 1. Access the statistics widget or custom fields in the dashboard 

73. 2. Update the following fields: 

74.    - Day (e.g., 'Day 109') 

75.    - Date (e.g., '20/08/2024') 



76.    - Sold Mass (e.g., '51,287 KGS') 

77.    - YTD Mass (Year-to-Date total, e.g., '230,906,318') 

78.    - Average Price (e.g., '3.43US$/KG') 

79. 8. Save changes 

80. 9. Refresh the homepage to verify updates 

 

Note: Market statistics are highly visible on the homepage. Ensure accuracy and update 

promptly during auction periods. Double-check all numbers before publishing. 

3.8 Using the Page Builder (Elementor) 

Elementor or the theme's page builder allows you to create custom layouts without 

coding. 

Launching the Page Builder 

81. 1. Edit the page you want to customize 

82. 2. Click 'Edit with Elementor' (or page builder button) 

83. 3. The visual editor will load 

84. 4. Add sections and widgets from the left panel 

85. 5. Drag and drop elements to position them 

86. 6. Click on any element to edit its settings 

87. 7. Use the responsive mode icons to preview mobile/tablet views 

88. 8. Click 'Update' to save changes 

89. 9. Click 'Exit' to return to WordPress dashboard 

Common Page Builder Elements 

• Heading: Add styled titles and headings 

• Text Editor: Add formatted text content 

• Image: Insert single images 

• Image Gallery: Create photo galleries 

• Button: Add call-to-action buttons 

• Divider: Add visual separators 

• Spacer: Control spacing between elements 

• Icon Box: Combine icons with text 

• Video: Embed videos from YouTube/Vimeo 

• Accordion: Create collapsible content sections 

• Tabs: Organize content in tabbed sections 

• Testimonial: Display quotes and testimonials 

  



4. Theme Customization 
The UI-Core Pro theme (or your installed theme) provides extensive customization 

options through the WordPress Customizer and theme settings panel. 

4.1 Accessing Theme Settings 

You can customize the theme through: 

• Appearance → Customize (WordPress Customizer) 

• Appearance → Theme Options/Settings (theme-specific panel) 

• Customize button in the top admin bar (when viewing site) 

4.2 Site Identity 

Configure basic site information: 

• Site Title: TIMB - Tobacco Industry and Marketing Board 

• Tagline: Your organization's tagline or slogan 

• Logo: Upload TIMB logo (recommended: PNG with transparency, 250px wide) 

• Site Icon/Favicon: Small icon for browser tabs (512 x 512 px, PNG) 

4.3 Color Scheme 

Maintain brand consistency by using TIMB's official colors throughout the site. 

• Primary Color: Main brand color (TIMB green) 

• Secondary Color: Accent color for highlights 

• Text Color: Main body text (usually dark gray or black) 

• Link Color: Hyperlink color 

• Hover Color: Color when hovering over links/buttons 

• Header Background: Top bar and header background 

• Footer Background: Footer section background 

 

      Tip: Use the official TIMB brand colors to maintain consistency. Test color contrast 

for accessibility (text should be easily readable against backgrounds). 

4.4 Typography 

Control fonts and text appearance: 

• Body font family and size 

• Heading fonts (H1 through H6) 

• Font weights (regular, bold) 

• Line height and letter spacing 

• Text transformation (uppercase, capitalize) 



4.5 Header & Footer 

 

Header Settings 

• Logo position and size 

• Top bar content (phone, email, market statistics) 

• Main navigation style 

• Header transparency 

• Sticky header (remains visible when scrolling) 

• Mobile menu configuration 

Footer Settings 

• Footer widget areas (columns) 

• Copyright text 

• Footer menu links 

• Social media icons 

• Contact information 

• Footer background color/image 

4.6 Homepage Configuration 

Configure what displays on the homepage: 

90. 1. Navigate to Settings → Reading 

91. 2. Choose: 

92.    - 'Your latest posts' (blog-style homepage) 

93.    - 'A static page' (custom homepage) 

94. 5. If choosing static page, select which page to use as homepage 

95. 6. Select a page for the Posts/Blog section 

96. 7. Click 'Save Changes' 

  



5. User & Access Management 
Proper user management ensures that team members have appropriate access levels 

while maintaining site security. 

5.1 Understanding User Roles 

Role Capabilities Use Case 

Administrator Full control over all 
aspects of the site 

Site managers, IT staff 

Editor Create, edit, publish, and 
delete all content 

Content managers, senior 
staff 

Author Create, edit, and publish 
own content 

Regular content creators 

Contributor Create and edit own 
content (needs approval to 
publish) 

Guest writers, interns 

Subscriber Profile access only Newsletter subscribers 

5.2 Adding New Users 

97. 1. Navigate to Users → Add New 

98. 2. Enter username (cannot be changed later - use email format recommended) 

99. 3. Enter user's email address 

100. 4. Enter first and last name 

101. 5. Generate a strong password or create one manually 

102. 6. Select appropriate role based on responsibilities 

103. 7. Check 'Send User Notification' to email login details 

104. 8. Click 'Add New User' 

105. 9. Instruct user to change password on first login 

5.3 Editing User Accounts 

106. 1. Navigate to Users → All Users 

107. 2. Locate the user account 

108. 3. Click on username or hover and click 'Edit' 

109. 4. Update role if needed 

110. 5. Modify contact information 

111. 6. Reset password if necessary (check 'Send password reset email') 

112. 7. Click 'Update User' 

5.4 Removing User Access 
113. 1. Navigate to Users → All Users 

114. 2. Hover over the user and click 'Delete' (or select multiple users) 

115. 3. Choose what to do with user's content: 

116.    - Delete all content (use cautiously) 

117.    - Attribute content to another user (recommended) 

118. 6. Click 'Confirm Deletion' 



 

    Important: When removing a user who has created content, always attribute their 

content to another user rather than deleting it. This preserves important posts and 

pages. 

5.5 User Management Best Practices 

• Review user accounts quarterly and remove inactive users 

• Use the principle of least privilege (minimum necessary permissions) 

• Limit Administrator role to 2-3 trusted individuals 

• Require strong passwords (8+ characters, mixed case, numbers, symbols) 

• Enable two-factor authentication for all admin users (if available) 

• Never share login credentials between users 

• Document who has access and their role 

• Immediately revoke access for departing staff 

• Monitor user activity through activity logs 

• Require password changes every 90 days 

  



6. Monitoring & Reports 
Regular monitoring helps you understand site performance, visitor behavior, and content 

effectiveness. 

6.1 Google Analytics 

If Google Analytics is installed, you can access detailed visitor statistics. 

Accessing Analytics 

• Directly at analytics.google.com (external) 

• Through WordPress dashboard widget (if plugin installed) 

• Via dedicated analytics plugin reports page 

Key Metrics to Monitor 

• Users: Number of unique visitors to your site 

• Sessions: Number of visits (one user can have multiple sessions) 

• Pageviews: Total pages viewed across all visits 

• Bounce Rate: Percentage of visitors who leave after viewing only one page 

• Session Duration: Average time visitors spend on your site 

• Traffic Sources: Where visitors come from (organic search, direct, social, referral) 

• Top Pages: Most viewed pages on your site 

• Geographic Data: Where your visitors are located 

• Device Category: Desktop vs. mobile vs. tablet usage 

6.2 WordPress Site Health 

WordPress includes a built-in site health tool that identifies issues. 

119. 1. Navigate to Tools → Site Health 

120. 2. Review the health status (Good, Should be improved, Critical) 

121. 3. Check the 'Status' tab for active issues 

122. 4. Review the 'Info' tab for technical details 

123. 5. Address any critical issues immediately 

124. 6. Work through recommendations to improve performance 

6.3 Activity Logs 

If an activity log plugin is installed, you can track all actions taken on your site. 

What Activity Logs Track 

• User logins and logouts 

• Content creation, editing, and deletion 

• Plugin and theme installations/updates 

• Settings changes 

• User account modifications 

• Failed login attempts 

• File uploads and deletions 



Reviewing Activity Logs 

125. 1. Navigate to the activity log plugin page (varies by plugin) 

126. 2. Use filters to narrow down by: 

127.    - User 

128.    - Date range 

129.    - Action type 

130.    - Content type 

131. 7. Review suspicious activity 

132. 8. Export logs if needed for audit purposes 

6.4 Performance Monitoring 

Monitor site speed and performance: 

• Google PageSpeed Insights: Comprehensive performance analysis with 

recommendations 

• GTmetrix: Detailed speed reports and waterfall charts 

• Pingdom: Global speed testing from multiple locations 

• WordPress Query Monitor: Plugin for debugging slow database queries 

Performance Targets 

• Page load time: Under 3 seconds 

• Time to First Byte (TTFB): Under 200ms 

• Largest Contentful Paint (LCP): Under 2.5 seconds 

• First Input Delay (FID): Under 100ms 

• Cumulative Layout Shift (CLS): Under 0.1 

• Mobile performance: Same or similar to desktop 

6.5 SEO Monitoring 

Track your site's search engine visibility: 

• Google Search Console for search performance data 

• SEO plugin dashboard (Yoast, Rank Math, etc.) 

• Keyword ranking tracking tools 

• Backlink monitoring 

• Crawl error reports 

• XML sitemap submissions 

• Search appearance in results (rich snippets, featured snippets) 

  



7. Troubleshooting Quick Guide 
This section provides solutions to common issues you may encounter. 

7.1 Common Issues & Solutions 

Issue 

Solution Steps 

 

Can't login to admin panel 

1. Verify username/email and password 

2. Check if account is active 

3. Clear browser cache and cookies 

4. Try different browser or incognito mode 

5. Use 'Lost your password?' to reset 

6. Contact administrator to verify account exists 

 

Forgot password 

1. Click 'Lost your password?' on login page 

2. Enter your email address 

3. Check email for reset link 

4. Check spam folder if not received 

5. Contact administrator if link doesn't arrive 

 

Can't upload media files 

1. Check file size (must be under server limit, usually 10MB) 

2. Verify file format is supported 

3. Try compressing large images 

4. Check browser console for error messages 

5. Contact hosting provider about server limits 

 



Changes not appearing on live site 

1. Clear your browser cache (Ctrl+F5) 

2. Clear website cache (if caching plugin installed) 

3. Verify changes were saved/published 

4. Check if viewing correct page 

5. Try different browser or incognito mode 

 

Page not found (404 error) 

1. Verify page is published (not draft) 

2. Check URL spelling 

3. Reset permalinks: Settings → Permalinks → Save 

4. Check if page was deleted 

5. Search for page in admin panel 

 

Images not displaying 

1. Verify image was uploaded successfully 

2. Check image URL is correct 

3. Clear cache (browser and site) 

4. Check file permissions on server 

5. Re-upload image if necessary 

 

Site is slow 

1. Clear cache (if caching plugin installed) 

2. Optimize images (compress large files) 

3. Deactivate unused plugins 

4. Check hosting resources 

5. Run performance test to identify bottlenecks 

 



White screen / blank page 

1. Increase PHP memory limit 

2. Deactivate recently installed plugins 

3. Switch to default theme 

4. Check error logs 

5. Contact Tech24 Group support immediately 

 

Plugin conflict 

1. Deactivate all plugins 

2. Reactivate plugins one by one 

3. Test site after each activation 

4. Identify problematic plugin 

5. Find alternative or contact plugin developer 

 

Market statistics not updating 

1. Verify you have permission to edit statistics 

2. Check correct fields are being updated 

3. Clear cache after updating 

4. Refresh homepage to verify changes 

5. Check if statistics widget is properly configured 

 

7.2 Browser-Specific Issues 

• Always use the latest version of your browser 

• Clear cache and cookies regularly (Ctrl+Shift+Delete) 

• Try incognito/private mode to rule out extension conflicts 

• Disable browser extensions temporarily if experiencing issues 

• Recommended browsers: Chrome, Firefox, Edge, Safari (latest versions) 

• Avoid Internet Explorer (no longer supported) 

7.3 When to Contact Support 

Contact Tech24 Group support if: 



• You've tried troubleshooting steps and issue persists 

• Site is completely down or inaccessible 

• You suspect a security breach 

• You need to restore from backup 

• Critical functionality is broken 

• You need additional training or guidance 

• You want to request new features or modifications 

Information to Provide When Reporting Issues 

• Clear description of the problem 

• Steps to reproduce the issue 

• When the issue started occurring 

• Recent changes made before issue appeared 

• Error messages (exact wording or screenshots) 

• Browser and version being used 

• Device type (desktop, tablet, mobile) 

• Your user role and permissions 

• Screenshots or screen recording of the issue 

  



8. Best Practices 

8.1 Content Creation Best Practices 

• Write clear, concise headlines that accurately describe content 

• Use proper grammar and spelling (proofread before publishing) 

• Break content into short paragraphs (2-4 sentences each) 

• Use headings (H2, H3) to organize long content 

• Include relevant images with every post/page 

• Always add alt text to images for accessibility 

• Use bullet points and numbered lists for easy scanning 

• Link to related content internally 

• Include a clear call-to-action where appropriate 

• Write for your audience (tobacco growers, buyers, stakeholders) 

• Keep industry information accurate and up-to-date 

• Cite sources for statistics and data 

8.2 Image Best Practices 

• Always optimize images before uploading (resize and compress) 

• Use descriptive filenames (tobacco-farmer-2025.jpg, not IMG_1234.jpg) 

• Target file size: under 500KB for fast loading 

• Use JPG for photographs, PNG for graphics/logos 

• Add alt text to every image (describe what's in the image) 

• Use consistent image dimensions for galleries 

• Ensure images are clear and high quality 

• Use relevant images that support your content 

• Respect copyright - only use authorized images 

• Consider image diversity and representation 

8.3 SEO Best Practices 

• Write unique, descriptive page titles (50-60 characters) 

• Create compelling meta descriptions (150-160 characters) 

• Use target keywords naturally in content 

• Structure content with proper heading hierarchy (H1 → H2 → H3) 

• Create descriptive URLs (use-keywords-not-numbers) 

• Link to related content internally 

• Encourage social sharing with quality content 

• Keep content fresh and updated 

• Mobile-optimize all content 

• Improve page load speed 

• Submit sitemap to Google Search Console 

• Fix broken links promptly 



8.4 Security Best Practices 

• Use strong, unique passwords (12+ characters, mixed case, numbers, symbols) 

• Enable two-factor authentication if available 

• Never share login credentials 

• Log out when finished, especially on shared computers 

• Keep WordPress, themes, and plugins updated 

• Only install plugins from trusted sources 

• Review user accounts regularly and remove inactive users 

• Use secure connections (HTTPS) always 

• Be cautious with email links (phishing prevention) 

• Report suspicious activity immediately 

• Backup site regularly (or verify backups are running) 

• Review activity logs periodically 

8.5 Content Workflow Best Practices 

• Plan content in advance (use content calendar) 

• Draft content offline first for major pieces 

• Save drafts frequently while working 

• Use categories and tags consistently 

• Preview content before publishing 

• Proofread carefully 

• Schedule posts for optimal publishing times 

• Review and update old content periodically 

• Archive outdated information 

• Monitor published content for errors 

• Respond to comments promptly 

• Track content performance with analytics 

8.6 Market Statistics Update Best Practices 

• Update statistics daily during auction season 

• Verify all numbers before publishing 

• Use consistent formatting (commas, decimals, units) 

• Update at the same time each day for consistency 

• Double-check calculations for YTD figures 

• Keep historical data archived for reference 

• Ensure data sources are reliable and official 

• Clear cache after updating to ensure visibility 

• Test homepage display after updates 

• Document data sources and methodology 

 



      Important: Market statistics are one of the most visible and frequently accessed 

features of the TIMB website. Accuracy and timeliness are critical for maintaining trust 

and credibility with stakeholders. 

  



9. Support & Contact Information 

9.1 Technical Support - Tech24 Group 

Company: Tech24 Group 

Primary Contact: Mr T. Mudzingwa 

Email: takudzwa@tech24group.com 

Alternate Email: tfmudzingwa@tech24group.com 

Response Time: 24-48 hours for non-critical issues 

Emergency Support: Available for critical site issues 

Support Hours: Monday - Friday, 8:00 AM - 5:00 PM CAT 

 

What Tech24 Group Supports 

• WordPress core issues and updates 

• Theme customization and updates 

• Plugin installation and configuration 

• Technical errors and bugs 

• Performance optimization 

• Security issues 

• Backup and restore 

• Hosting-related issues 

• Custom development requests 

• Training and guidance 

9.2 Internal TIMB IT Support 

For internal IT matters, user account issues, or general inquiries: 

Department: TIMB IT Department 

Email: xxxx@timb.co.zw 

Address: 429 Gleneagles Road, Southerton, Harare, Zimbabwe 

9.3 Emergency Contacts 

For critical website issues: 

Issue Type Contact Action Required 

Site completely down Tech24 Group immediately Call support line or email 

Security breach 
suspected 

Tech24 Group + TIMB IT Do not make changes, 
report immediately 



Data loss or corruption Tech24 Group/ TIMB Request backup 
restoration 

Incorrect market data 
published 

TIMB IT + responsible staff Correct immediately, 
document incident 

Defacement or hacking Tech24 Group immediately Document evidence, 
change passwords 

9.4 Training & Additional Documentation 

Additional training and documentation resources: 

• WordPress Codex: Official WordPress documentation - wordpress.org/support 

• WordPress TV: Video tutorials - wordpress.tv 

• Theme Documentation: Contact Tech24 Group for UI-Core Pro documentation 

• On-Site Training: Available upon request from Tech24 Group 

• Custom Training Manual: This document and any updates provided 

9.5 Feedback & Suggestions 

We welcome your feedback on the website and this documentation: 

• Email suggestions to Tech24 Group 

• Report bugs or issues through support channels 

• Request new features or improvements 

• Provide feedback on training materials 

• Share user experience insights 

 

Note: Your feedback helps us improve the website and this manual. Don't hesitate to 

reach out with questions, suggestions, or concerns. 

  



Appendix 

A. Quick Reference Guide 

Task Navigation Path 

Add new page Pages → Add New 

Add news/blog post Posts → Add New 

Upload images Media → Add New 

Edit menus Appearance → Menus 

Customize theme Appearance → Customize 

Manage users Users → All Users 

View site health Tools → Site Health 

Update plugins Plugins → Installed Plugins 

General settings Settings → General 

Permalink settings Settings → Permalinks 

Change password Users → Profile → Account Management 

B. Keyboard Shortcuts 

Shortcut 
(Windows/Linux) 

Shortcut (Mac) Action 

Ctrl + S Cmd + S Save draft 

Ctrl + B Cmd + B Bold text 

Ctrl + I Cmd + I Italic text 

Ctrl + K Cmd + K Insert/edit link 

Ctrl + Z Cmd + Z Undo 

Ctrl + Y Cmd + Y Redo 

Ctrl + Shift + Delete Cmd + Shift + Delete Clear browser cache 

F5 Cmd + R Refresh page 

Ctrl + F5 Cmd + Shift + R Hard refresh (clear cache) 

C. File Size & Format Guidelines 

File Type Recommended 
Formats 

Maximum Size Notes 

Images JPG, PNG 500 KB - 1 MB Compress before 
upload 

Documents PDF 5 MB Use for 
publications, 
reports 

Logos/Graphics PNG (with 
transparency) 

200 KB SVG acceptable if 
supported 

Presentations PDF 10 MB Convert 
PowerPoint to PDF 

Videos External hosting N/A Use 
YouTube/Vimeo, 
don't upload 
directly 



D. Glossary of Terms 

Admin Bar: Top toolbar visible to logged-in users 

Alt Text: Alternative text describing images for accessibility 

Backend: Administrative area of WordPress (wp-admin) 

Cache: Temporary storage of web pages for faster loading 

Category: Broad grouping for posts 

CMS: Content Management System 

Dashboard: Main administrative interface in WordPress 

Excerpt: Short summary of a post 

Featured Image: Main image representing a post or page 

Frontend: Public-facing side of website 

HTTPS: Secure connection protocol 

Media Library: Repository for all uploaded files 

Meta Description: Summary text for search engines 

Page: Static content (About, Contact, etc.) 

Permalink: Permanent URL for content 

Plugin: Extension that adds functionality to WordPress 

Post: Blog entry or news article 

Publish: Make content live on website 

Responsive: Adapts to different screen sizes 

SEO: Search Engine Optimization 

Sidebar: Widget area on side of pages 

Slug: URL-friendly version of title 

Tag: Specific keyword describing content 

Theme: Design and layout template 

Widget: Small content block in sidebar/footer 

WYSIWYG: What You See Is What You Get editor 



E. Document Version History 

Version Date Author Changes 

1.0 2026-01-27 Tech24 Group Initial release - 
comprehensive 
user manual for 
TIMB website 
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For questions, updates, or additional training, 

please contact Tech24 Group or the TIMB IT Department. 
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